macos brew 安装 PHP 7.2 提示 php@7.2 has been disabled because it is deprecated upstream!

yufei       1 月 前       106

一套古老的代码要修复一个 bug,尝试本地运行一下,发现报错,因为 composer.json 文件限制 PHP 必须是 7.2 版本

...
    "require" : {
        "php": "^7.2",
...

既然要求 7.2 ,那我们就安装一下呗

brew search php

结果如下

==> Formulae
brew-php-switcher    php-cs-fixer@2       php@8.0              phpmyadmin           pup
php                 php@7.2              phpbrew              phpstan
php-code-sniffer     php@7.3              phplint              phpunit
php-cs-fixer         php@7.4              phpmd                pcp

但,运行

brew install php@7.2

的时候就坑了, 提示

php@7.2 has been disabled because it is deprecated upstream

那要怎么办呢? 要不看看 tap 上有没有,比如说

brew tap shivammathur/php

然后用下面的命令安装就可以了

brew install shivammathur/php/php@7.2
目前尚无回复
简单教程 = 简单教程,简单编程
简单教程 是一个关于技术和学习的地方
现在注册
已注册用户请 登入
关于   |   FAQ   |   我们的愿景   |   广告投放   |  博客

  简单教程,简单编程 - IT 入门首选站

Copyright © 2013-2022 简单教程 twle.cn All Rights Reserved.